Denial of Service and Content Injection in i18n-node-angular
CVE-2016-10524GHSA-97gv-3p2c-xw7j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18n-node-angular 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-97gv-3p2c-xw7j lists affected ranges: npm i18n-node-angular >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-97gv-3p2c-xw7j lists affected ranges: npm i18n-node-angular >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H
- EPSS
- CVE-2016-10524: 0.79% estimated exploitation activity in the next 30 days; percentile 56.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of i18n-node-angular prior to 1.4.0 are affected by denial of service and cross-site scripting vulnerabilities. The vulnerabilities exist in a REST endpoint that was created for development purposes, but was not disabled in production in affected versions. Recommendation Update to version 1.4.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-97gv-3p2c-xw7j
- Revision 1 · created ·
Published from osv record GHSA-97gv-3p2c-xw7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10524 Advisory: Denial of Service and Content Injection in i18n-node-angular IDs: CVE-2016-10524, GHSA-97gv-3p2c-xw7j Record: https://patchnext.com/advisories/cve-2016-10524 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18n-node-angular 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18n-node-angular: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `npm ls i18n-node-angular --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18n-node-angular. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-97gv-3p2c-xw7j (OSV record GHSA-97gv-3p2c-xw7j lists affected ranges: npm i18n-node-angular >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-97gv-3p2c-xw7j (GitHub-reviewed advisory GHSA-97gv-3p2c-xw7j lists affected ranges: npm i18n-node-angular >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…