Skip to content

← Actionable
High, CVSS 8.8

Cross-site request forgery in rails_admin

CVE-2016-10522GHSA-pxqr-8v54-m2hj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails_admin 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rails_admin

    Affected
    >= 1.0.0, < 1.1.1
    Fixed in
    1.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2016-10522: 0.98% estimated exploitation activity in the next 30 days; percentile 62.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

railsadmin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pxqr-8v54-m2hj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10522

Advisory: Cross-site request forgery in rails_admin
IDs: CVE-2016-10522, GHSA-pxqr-8v54-m2hj
Record: https://patchnext.com/advisories/cve-2016-10522 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rails_admin 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rails_admin: affected >= 1.0.0, < 1.1.1; fixed in 1.1.1

## Suggested inspection (read-only)
- RubyGems rails_admin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rails_admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pxqr-8v54-m2hj (GitHub-reviewed advisory GHSA-pxqr-8v54-m2hj lists affected ranges: RubyGems rails_admin >=1.0.0 <1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…