Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Remote code execution in PHPMailer

CVE-2016-10033GHSA-5f37-gxvh-23v6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 5.2.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2016-10033: 99.71% estimated exploitation activity in the next 30 days; percentile 99.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The mailSend function in the default isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property. Patches Fixed in 5.2.18 Workarounds Filter and validate user input before passing it to internal functions. References https://nvd.nist.gov/vuln/detail/CVE-2016-10033 Related to a follow-on issue in https://nvd.nist.gov/vuln/detail/CVE-2016-10045 For more information If you have any questions or comments about this advisory: Open a private issue in the PHPMailer project

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5f37-gxvh-23v6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10033

Advisory: Remote code execution in PHPMailer
IDs: CVE-2016-10033, GHSA-5f37-gxvh-23v6
Record: https://patchnext.com/advisories/cve-2016-10033 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 5.2.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmailer/phpmailer: affected >= 5.0.0, < 5.2.18; fixed in 5.2.18

## Suggested inspection (read-only)
- Packagist phpmailer/phpmailer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmailer/phpmailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5f37-gxvh-23v6 (GitHub-reviewed advisory GHSA-5f37-gxvh-23v6 lists affected ranges: Packagist phpmailer/phpmailer >=5.0.0 <5.2.18)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2016-10033 to the Known Exploited Vulnerabilities catalog on 2025-07-07.)

Commands are suggestions: review each one before running it.

Loading voting…