In Bouncy Castle JCE Provider the DSA key pair generator generates a weak private key if used with default values
CVE-2016-1000343GHSA-rrvx-pwf8-p59p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bcprov-jdk14 1.56; org.bouncycastle:bcprov-jdk15 1.56; org.bouncycastle:bcprov-jdk15on 1.56), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bcprov-jdk14
- Affected
- < 1.56
- Fixed in
- 1.56
Maven org.bouncycastle:bcprov-jdk15
- Affected
- < 1.56
- Fixed in
- 1.56
Maven org.bouncycastle:bcprov-jdk15on
- Affected
- < 1.56
- Fixed in
- 1.56
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrvx-pwf8-p59p lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=0 =0 =0 <1.56
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2016-1000343: 3.25% estimated exploitation activity in the next 30 days; percentile 88.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In the Bouncy Castle JCE Provider version 1.55 and earlier the DSA key pair generator generates a weak private key if used with default values. If the JCA key pair generator is not explicitly initialised with DSA parameters, 1.55 and earlier generates a private value assuming a 1024 bit key size. In earlier releases this can be dealt with by explicitly passing parameters to the key pair generator.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rrvx-pwf8-p59p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-1000343 Advisory: In Bouncy Castle JCE Provider the DSA key pair generator generates a weak private key if used with default values IDs: CVE-2016-1000343, GHSA-rrvx-pwf8-p59p Record: https://patchnext.com/advisories/cve-2016-1000343 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bcprov-jdk14 1.56; org.bouncycastle:bcprov-jdk15 1.56; org.bouncycastle:bcprov-jdk15on 1.56. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bcprov-jdk14: affected < 1.56; fixed in 1.56 - Maven org.bouncycastle:bcprov-jdk15: affected < 1.56; fixed in 1.56 - Maven org.bouncycastle:bcprov-jdk15on: affected < 1.56; fixed in 1.56 ## Suggested inspection (read-only) - Maven org.bouncycastle:bcprov-jdk14: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk15: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk15on: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bcprov-jdk14, org.bouncycastle:bcprov-jdk15, org.bouncycastle:bcprov-jdk15on. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rrvx-pwf8-p59p (GitHub-reviewed advisory GHSA-rrvx-pwf8-p59p lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=0 =0 =0 <1.56) Commands are suggestions: review each one before running it.
Loading voting…