guard-livereload has a directory traversal vulnerability
CVE-2016-1000305GHSA-g65v-27r3-5p6m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (guard-livereload 2.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems guard-livereload
- Affected
- < 2.5.2
- Fixed in
- 2.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g65v-27r3-5p6m lists affected ranges: RubyGems guard-livereload >=0 <2.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g65v-27r3-5p6m lists affected ranges: RubyGems guard-livereload >=0 <2.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The vulnerability allows remote attackers to read arbitrary files on the server by exploiting improper path validation in the livereload server functionality. This vulnerability is related to the handling of file paths in the livereload server component, which could allow an attacker to traverse directories and access files outside the intended web root directory. The issue was identified and reported through the DWF (Distributed Weakness Filing) project, which assigns CVE identifiers for security vulnerabilities. A directory traversal vulnerability exists in guard-livereload before version 2.5.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g65v-27r3-5p6m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g65v-27r3-5p6m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-1000305 Advisory: guard-livereload has a directory traversal vulnerability IDs: CVE-2016-1000305, GHSA-g65v-27r3-5p6m Record: https://patchnext.com/advisories/cve-2016-1000305 (revision 3, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: guard-livereload 2.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems guard-livereload: affected < 2.5.2; fixed in 2.5.2 ## Suggested inspection (read-only) - RubyGems guard-livereload: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on guard-livereload. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g65v-27r3-5p6m (OSV record GHSA-g65v-27r3-5p6m lists affected ranges: RubyGems guard-livereload >=0 <2.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-g65v-27r3-5p6m (GitHub-reviewed advisory GHSA-g65v-27r3-5p6m lists affected ranges: RubyGems guard-livereload >=0 <2.5.2) Commands are suggestions: review each one before running it.
Loading voting…