Pivotal Spring Framework contains unsafe Java deserialization methods
CVE-2016-1000027GHSA-4wrc-f8pq-fpqp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework:spring-web 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework:spring-web
- Affected
- < 6.0.0
- Fixed in
- 6.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4wrc-f8pq-fpqp lists affected ranges: Maven org.springframework:spring-web >=0 <6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-1000027: 33.18% estimated exploitation activity in the next 30 days; percentile 98.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pivotal Spring Framework before 6.0.0 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. Maintainers recommend investigating alternative components or a potential mitigating control. Version 4.2.6 and 3.2.17 contain enhanced documentation advising users to take precautions against unsafe Java deserialization, version 5.3.0 deprecate the impacted classes and version 6.0.0 removed it entirely.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4wrc-f8pq-fpqp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-1000027 Advisory: Pivotal Spring Framework contains unsafe Java deserialization methods IDs: CVE-2016-1000027, GHSA-4wrc-f8pq-fpqp Record: https://patchnext.com/advisories/cve-2016-1000027 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework:spring-web 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework:spring-web: affected < 6.0.0; fixed in 6.0.0 ## Suggested inspection (read-only) - Maven org.springframework:spring-web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework:spring-web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4wrc-f8pq-fpqp (GitHub-reviewed advisory GHSA-4wrc-f8pq-fpqp lists affected ranges: Maven org.springframework:spring-web >=0 <6.0.0) Commands are suggestions: review each one before running it.
Loading voting…