Apache Ranger Access Restriction Bypass
CVE-2016-0735GHSA-22v7-w6c5-v4rr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.ranger:ranger 0.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.ranger:ranger
- Affected
- >= 0.5.0, < 0.5.2
- Fixed in
- 0.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-22v7-w6c5-v4rr lists affected ranges: Maven org.apache.ranger:ranger >=0.5.0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-0735: 1.67% estimated exploitation activity in the next 30 days; percentile 76.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Ranger 0.5.x before 0.5.2 allows remote authenticated users to bypass intended parent resource-level access restrictions by leveraging mishandling of a resource-level exclude policy.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-22v7-w6c5-v4rr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-0735 Advisory: Apache Ranger Access Restriction Bypass IDs: CVE-2016-0735, GHSA-22v7-w6c5-v4rr Record: https://patchnext.com/advisories/cve-2016-0735 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.ranger:ranger 0.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.ranger:ranger: affected >= 0.5.0, < 0.5.2; fixed in 0.5.2 ## Suggested inspection (read-only) - Maven org.apache.ranger:ranger: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.ranger:ranger. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-22v7-w6c5-v4rr (GitHub-reviewed advisory GHSA-22v7-w6c5-v4rr lists affected ranges: Maven org.apache.ranger:ranger >=0.5.0 <0.5.2) Commands are suggestions: review each one before running it.
Loading voting…