Skip to content

← Actionable
Medium, CVSS 6.1

Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ

CVE-2016-0734GHSA-w525-w93j-rxgm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-client 5.13.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2016-0734: 8.62% estimated exploitation activity in the next 30 days; percentile 95.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The web-based administration console in Apache ActiveMQ 5.x before 5.13.2 does not send an X-Frame-Options HTTP header, which makes it easier for remote attackers to conduct clickjacking attacks via a crafted web page that contains a (1) FRAME or (2) IFRAME element.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w525-w93j-rxgm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-0734

Advisory: Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
IDs: CVE-2016-0734, GHSA-w525-w93j-rxgm
Record: https://patchnext.com/advisories/cve-2016-0734 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-client 5.13.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.activemq:activemq-client: affected >= 5.0.0, <= 5.13.1; fixed in 5.13.2

## Suggested inspection (read-only)
- Maven org.apache.activemq:activemq-client: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.activemq:activemq-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w525-w93j-rxgm (GitHub-reviewed advisory GHSA-w525-w93j-rxgm lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <=5.13.1)

Commands are suggestions: review each one before running it.

Loading voting…