Moodle Cross-site scripting (XSS) vulnerability in course management search
CVE-2016-0725GHSA-gj2j-ppjq-9pjg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.0.2, 2.9.4, 2.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 2.8, < 2.8.10>= 2.9, < 2.9.4>= 3.0, < 3.0.2
- Fixed in
- 3.0.2, 2.8.10, 2.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gj2j-ppjq-9pjg lists affected ranges: Packagist moodle/moodle >=2.8 =2.9 =3.0 <3.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2016-0725: 1.57% estimated exploitation activity in the next 30 days; percentile 75.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the searchpagination function in course/classes/managementrenderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gj2j-ppjq-9pjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-0725 Advisory: Moodle Cross-site scripting (XSS) vulnerability in course management search IDs: CVE-2016-0725, GHSA-gj2j-ppjq-9pjg Record: https://patchnext.com/advisories/cve-2016-0725 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.0.2, 2.9.4, 2.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 2.8, < 2.8.10; >= 2.9, < 2.9.4; >= 3.0, < 3.0.2; fixed in 3.0.2, 2.8.10, 2.9.4 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gj2j-ppjq-9pjg (GitHub-reviewed advisory GHSA-gj2j-ppjq-9pjg lists affected ranges: Packagist moodle/moodle >=2.8 =2.9 =3.0 <3.0.2) Commands are suggestions: review each one before running it.
Loading voting…