Skip to content

← Actionable
Medium, CVSS 4.3

Moodle sensitive information disclosure

CVE-2016-0724GHSA-hjrj-7wcj-7j3c

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    <= 2.6.11>= 2.7.0, < 2.7.12>= 2.8.0, < 2.8.10>= 2.9.0, < 2.9.4>= 3.0.0, < 3.0.2
    Fixed in
    3.0.2, 2.8.10, 2.9.4, 2.7.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2016-0724: 1.94% estimated exploitation activity in the next 30 days; percentile 80.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The (1) coreenrolgetcourseenrolmentmethods and (2) enrolselfgetinstanceinfo web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to obtain sensitive information via a web-service request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hjrj-7wcj-7j3c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-0724

Advisory: Moodle sensitive information disclosure
IDs: CVE-2016-0724, GHSA-hjrj-7wcj-7j3c
Record: https://patchnext.com/advisories/cve-2016-0724 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: moodle/moodle 3.0.2, 2.9.4, 2.8.10, 2.7.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected <= 2.6.11; >= 2.7.0, < 2.7.12; >= 2.8.0, < 2.8.10; >= 2.9.0, < 2.9.4; >= 3.0.0, < 3.0.2; fixed in 3.0.2, 2.8.10, 2.9.4, 2.7.12

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hjrj-7wcj-7j3c (GitHub-reviewed advisory GHSA-hjrj-7wcj-7j3c lists affected ranges: Packagist moodle/moodle >=0 =2.7.0 =2.8.0 =2.9.0 =3.0.0 <3.0.2)

Commands are suggestions: review each one before running it.

Loading voting…