Skip to content

← Actionable
Medium, CVSS 4.3

Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat

CVE-2016-0706GHSA-6vx3-hr43-cfrh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 9.0.0.M2, 8.0.31, 6.0.45), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    >= 9.0.0.M1, <= 9.0.0.M1>= 8.0.0.RC1, <= 8.0.30>= 6.0.0, <= 6.0.44
    Fixed in
    9.0.0.M2, 8.0.31, 6.0.45

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2016-0706: 6.23% estimated exploitation activity in the next 30 days; percentile 93.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 does not place org.apache.catalina.manager.StatusManagerServlet on the org/apache/catalina/core/RestrictedServlets.properties list, which allows remote authenticated users to bypass intended SecurityManager restrictions and read arbitrary HTTP requests, and consequently discover session ID values, via a crafted web application.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6vx3-hr43-cfrh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-0706

Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
IDs: CVE-2016-0706, GHSA-6vx3-hr43-cfrh
Record: https://patchnext.com/advisories/cve-2016-0706 (revision 1, source checked 26 Oct 2026, 16:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 9.0.0.M2, 8.0.31, 6.0.45. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 9.0.0.M1, <= 9.0.0.M1; >= 8.0.0.RC1, <= 8.0.30; >= 6.0.0, <= 6.0.44; fixed in 9.0.0.M2, 8.0.31, 6.0.45

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6vx3-hr43-cfrh (GitHub-reviewed advisory GHSA-6vx3-hr43-cfrh lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.0.M1 =8.0.0.RC1 =6.0.0 <=6.0.44)

Commands are suggestions: review each one before running it.

Loading voting…