Skip to content

← Actionable
Unratedamended

SQL Injection in mysql

CVE-2015-9244GHSA-fvq6-55gv-jx9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mysql 2.0.0-alpha8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mysql

    Affected
    <= 2.0.0-alpha7
    Fixed in
    2.0.0-alpha8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-9244: 2.44% estimated exploitation activity in the next 30 days; percentile 84.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of mysql prior to 2.0.0-alpha8 are affected by a SQL Injection vulnerability in the mysql.escape() function, which does not properly escape object keys. Recommendation Update to version 2.0.0-alpha8 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fvq6-55gv-jx9f

  2. Revision 1 · created ·

    Published from osv record GHSA-fvq6-55gv-jx9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-9244

Advisory: SQL Injection in mysql
IDs: CVE-2015-9244, GHSA-fvq6-55gv-jx9f
Record: https://patchnext.com/advisories/cve-2015-9244 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mysql 2.0.0-alpha8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mysql: affected <= 2.0.0-alpha7; fixed in 2.0.0-alpha8

## Suggested inspection (read-only)
- `npm ls mysql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mysql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fvq6-55gv-jx9f (OSV record GHSA-fvq6-55gv-jx9f lists affected ranges: npm mysql >=0 <2.0.0-alpha8 (fixed))
- Verified: https://github.com/advisories/GHSA-fvq6-55gv-jx9f (GitHub-reviewed advisory GHSA-fvq6-55gv-jx9f lists affected ranges: npm mysql >=0 <=2.0.0-alpha7)

Commands are suggestions: review each one before running it.

Loading voting…