Skip to content

← Actionable
Unratedamended

Unsafe Merging of CORS Configuration Conflict in hapi

CVE-2015-9243GHSA-j3g2-m5jj-6336

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hapi 11.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm hapi

    Affected
    < 11.1.4
    Fixed in
    11.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-9243: 1.02% estimated exploitation activity in the next 30 days; percentile 63.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of hapi prior to 11.1.4 are affected by a vulnerability that causes route-level CORS configuration to override connection-level or server-level CORS defaults. This may result in a situation where CORS permissions are less restrictive than intended. Recommendation Update hapi to version 11.1.4 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j3g2-m5jj-6336

  2. Revision 1 · created ·

    Published from osv record GHSA-j3g2-m5jj-6336

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-9243

Advisory: Unsafe Merging of CORS Configuration Conflict in hapi
IDs: CVE-2015-9243, GHSA-j3g2-m5jj-6336
Record: https://patchnext.com/advisories/cve-2015-9243 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hapi 11.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm hapi: affected < 11.1.4; fixed in 11.1.4

## Suggested inspection (read-only)
- `npm ls hapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j3g2-m5jj-6336 (OSV record GHSA-j3g2-m5jj-6336 lists affected ranges: npm hapi >=0 <11.1.4 (fixed))
- Verified: https://github.com/advisories/GHSA-j3g2-m5jj-6336 (GitHub-reviewed advisory GHSA-j3g2-m5jj-6336 lists affected ranges: npm hapi >=0 <11.1.4)

Commands are suggestions: review each one before running it.

Loading voting…