Skip to content

← Actionable
Unratedamended

Incorrect handling of CORS preflight request headers in hapi

CVE-2015-9236GHSA-vwrf-r5r4-7775

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hapi 11.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm hapi

    Affected
    < 11.0.0
    Fixed in
    11.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-9236: 1.52% estimated exploitation activity in the next 30 days; percentile 74.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of hapi prior to 11.0.0 implement CORS incorrectly, allowing for configurations that at best return inconsistent headers, and at worst allow cross-origin activities that are expected to be forbidden. If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route. Recommendation Update to version 11.0.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vwrf-r5r4-7775

  2. Revision 1 · created ·

    Published from osv record GHSA-vwrf-r5r4-7775

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-9236

Advisory: Incorrect handling of CORS preflight request headers in hapi
IDs: CVE-2015-9236, GHSA-vwrf-r5r4-7775
Record: https://patchnext.com/advisories/cve-2015-9236 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hapi 11.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm hapi: affected < 11.0.0; fixed in 11.0.0

## Suggested inspection (read-only)
- `npm ls hapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vwrf-r5r4-7775 (OSV record GHSA-vwrf-r5r4-7775 lists affected ranges: npm hapi >=0 <11.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vwrf-r5r4-7775 (GitHub-reviewed advisory GHSA-vwrf-r5r4-7775 lists affected ranges: npm hapi >=0 <11.0.0)

Commands are suggestions: review each one before running it.

Loading voting…