Skip to content

← Actionable
High, CVSS 7.5amended

Regular Expression Denial of Service in marked

CVE-2015-8854GHSA-hjcp-j389-59ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (marked 0.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm marked

    Affected
    < 0.3.4
    Fixed in
    0.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2015-8854: 4.42% estimated exploitation activity in the next 30 days; percentile 91.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions 0.3.3 and earlier of marked are affected by a regular expression denial of service ( ReDoS ) vulnerability when passed inputs that reach the em inline rule. Recommendation Update to version 0.3.4 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hjcp-j389-59ff

  2. Revision 1 · created ·

    Published from osv record GHSA-hjcp-j389-59ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-8854

Advisory: Regular Expression Denial of Service in marked
IDs: CVE-2015-8854, GHSA-hjcp-j389-59ff
Record: https://patchnext.com/advisories/cve-2015-8854 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: marked 0.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm marked: affected < 0.3.4; fixed in 0.3.4

## Suggested inspection (read-only)
- `npm ls marked --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on marked.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hjcp-j389-59ff (OSV record GHSA-hjcp-j389-59ff lists affected ranges: npm marked >=0 <0.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-hjcp-j389-59ff (GitHub-reviewed advisory GHSA-hjcp-j389-59ff lists affected ranges: npm marked >=0 <0.3.4)

Commands are suggestions: review each one before running it.

Loading voting…