Typo3 XSS Vulnerability
CVE-2015-8755GHSA-56f9-5563-m2h7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms 7.6.1, 6.2.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms
- Affected
- >= 6.2, < 6.2.16>= 7.0, < 7.6.1
- Fixed in
- 6.2.16, 7.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-56f9-5563-m2h7 lists affected ranges: Packagist typo3/cms >=6.2 =7.0 <7.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2015-8755: 1.14% estimated exploitation activity in the next 30 days; percentile 66.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 6.2.x before 6.2.16 and 7.x before 7.6.1 allow remote authenticated editors to inject arbitrary web script or HTML via unknown vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-56f9-5563-m2h7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-8755 Advisory: Typo3 XSS Vulnerability IDs: CVE-2015-8755, GHSA-56f9-5563-m2h7 Record: https://patchnext.com/advisories/cve-2015-8755 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms 7.6.1, 6.2.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms: affected >= 6.2, < 6.2.16; >= 7.0, < 7.6.1; fixed in 6.2.16, 7.6.1 ## Suggested inspection (read-only) - Packagist typo3/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-56f9-5563-m2h7 (GitHub-reviewed advisory GHSA-56f9-5563-m2h7 lists affected ranges: Packagist typo3/cms >=6.2 =7.0 <7.6.1) Commands are suggestions: review each one before running it.
Loading voting…