Silverstripe CMS XSS Vulnerability
CVE-2015-8606GHSA-gvc8-xjfp-6569
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/cms 3.2.1, 3.1.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/cms
- Affected
- <= 3.1.15>= 3.2.0, <= 3.2.0
- Fixed in
- 3.2.1, 3.1.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gvc8-xjfp-6569 lists affected ranges: Packagist silverstripe/cms >=0 =3.2.0 <=3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2015-8606: 1.54% estimated exploitation activity in the next 30 days; percentile 74.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework before 3.1.16 and 3.2.0 before 3.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) Locale or (2) FailedLoginCount parameter to admin/security/EditForm/field/Members/item/new/ItemEditForm.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gvc8-xjfp-6569
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-8606 Advisory: Silverstripe CMS XSS Vulnerability IDs: CVE-2015-8606, GHSA-gvc8-xjfp-6569 Record: https://patchnext.com/advisories/cve-2015-8606 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/cms 3.2.1, 3.1.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/cms: affected <= 3.1.15; >= 3.2.0, <= 3.2.0; fixed in 3.2.1, 3.1.16 ## Suggested inspection (read-only) - Packagist silverstripe/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gvc8-xjfp-6569 (GitHub-reviewed advisory GHSA-gvc8-xjfp-6569 lists affected ranges: Packagist silverstripe/cms >=0 =3.2.0 <=3.2.0) Commands are suggestions: review each one before running it.
Loading voting…