Skip to content

← Actionable
Low, CVSS 3.1

Symfony Session Fixation Vulnerability

CVE-2015-8124GHSA-j5jh-hpr4-h332

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.7.7, 2.6.12, 2.3.35; symfony/security-http 2.7.7, 2.6.12; symfony/security 2.7.7, 2.6.12, 2.3.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.3.0, < 2.3.35>= 2.4.0, < 2.6.12>= 2.7.0, < 2.7.7
    Fixed in
    2.6.12, 2.7.7, 2.3.35
  • Packagist symfony/security-http

    Affected
    >= 2.4.0, < 2.6.12>= 2.7.0, < 2.7.7
    Fixed in
    2.6.12, 2.7.7
  • Packagist symfony/security

    Affected
    >= 2.3.0, < 2.3.35>= 2.4.0, < 2.6.12>= 2.7.0, < 2.7.7
    Fixed in
    2.6.12, 2.7.7, 2.3.35

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-j5jh-hpr4-h332 lists affected ranges: Packagist symfony/symfony >=2.3.0 =2.4.0 =2.7.0 =2.4.0 =2.7.0 =2.3.0 =2.4.0 =2.7.0 <2.7.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2015-8124: 2.71% estimated exploitation activity in the next 30 days; percentile 86.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A session fixation vulnerability within the "Remember Me" login feature allows an attacker to impersonate the victim towards the web application if the session id value was previously known to the attacker. This issue has been fixed in Symfony 2.3.35, 2.6.12, and 2.7.7. Note that no fixes are provided for Symfony 2.4 and 2.5 as they are not maintained anymore. Symfony 2.8 and 3.0 haven't been released yet and the fix will be included in their first stable releases.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j5jh-hpr4-h332

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-8124

Advisory: Symfony Session Fixation Vulnerability
IDs: CVE-2015-8124, GHSA-j5jh-hpr4-h332
Record: https://patchnext.com/advisories/cve-2015-8124 (revision 1, source checked 26 Oct 2026, 14:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.7.7, 2.6.12, 2.3.35; symfony/security-http 2.7.7, 2.6.12; symfony/security 2.7.7, 2.6.12, 2.3.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.3.0, < 2.3.35; >= 2.4.0, < 2.6.12; >= 2.7.0, < 2.7.7; fixed in 2.6.12, 2.7.7, 2.3.35
- Packagist symfony/security-http: affected >= 2.4.0, < 2.6.12; >= 2.7.0, < 2.7.7; fixed in 2.6.12, 2.7.7
- Packagist symfony/security: affected >= 2.3.0, < 2.3.35; >= 2.4.0, < 2.6.12; >= 2.7.0, < 2.7.7; fixed in 2.6.12, 2.7.7, 2.3.35

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security-http: check the installed version with your package manager.
- Packagist symfony/security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/security-http, symfony/security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j5jh-hpr4-h332 (GitHub-reviewed advisory GHSA-j5jh-hpr4-h332 lists affected ranges: Packagist symfony/symfony >=2.3.0 =2.4.0 =2.7.0 =2.4.0 =2.7.0 =2.3.0 =2.4.0 =2.7.0 <2.7.7)

Commands are suggestions: review each one before running it.

Loading voting…