rails-html-sanitizer Cross-site Scripting vulnerability
CVE-2015-7579GHSA-r9c2-cr39-c8g6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails-html-sanitizer 1.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rails-html-sanitizer
- Affected
- < 1.0.3
- Fixed in
- 1.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r9c2-cr39-c8g6 lists affected ranges: RubyGems rails-html-sanitizer >=0 <1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2015-7579: 2.58% estimated exploitation activity in the next 30 days; percentile 85.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem 1.0.2 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via an HTML entity that is mishandled by the Rails::Html::FullSanitizer class.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r9c2-cr39-c8g6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-7579 Advisory: rails-html-sanitizer Cross-site Scripting vulnerability IDs: CVE-2015-7579, GHSA-r9c2-cr39-c8g6 Record: https://patchnext.com/advisories/cve-2015-7579 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rails-html-sanitizer 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rails-html-sanitizer: affected < 1.0.3; fixed in 1.0.3 ## Suggested inspection (read-only) - RubyGems rails-html-sanitizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rails-html-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r9c2-cr39-c8g6 (GitHub-reviewed advisory GHSA-r9c2-cr39-c8g6 lists affected ranges: RubyGems rails-html-sanitizer >=0 <1.0.3) Commands are suggestions: review each one before running it.
Loading voting…