Skip to content

← Actionable
Critical, CVSS 10.0

colorscore Command Injection vulnerability

CVE-2015-7541GHSA-73qw-ww62-m54x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (colorscore 0.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2015-7541: 3.53% estimated exploitation activity in the next 30 days; percentile 89.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The initialize method in the Histogram class in lib/colorscore/histogram.rb in the colorscore gem before 0.0.5 for Ruby allows context-dependent attackers to execute arbitrary code via shell metacharacters in the (1) imagepath, (2) colors, or (3) depth variable.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-73qw-ww62-m54x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-7541

Advisory: colorscore Command Injection vulnerability
IDs: CVE-2015-7541, GHSA-73qw-ww62-m54x
Record: https://patchnext.com/advisories/cve-2015-7541 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: colorscore 0.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems colorscore: affected < 0.0.5; fixed in 0.0.5

## Suggested inspection (read-only)
- RubyGems colorscore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on colorscore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-73qw-ww62-m54x (GitHub-reviewed advisory GHSA-73qw-ww62-m54x lists affected ranges: RubyGems colorscore >=0 <0.0.5)

Commands are suggestions: review each one before running it.

Loading voting…