Skip to content

← Actionable
Low, CVSS 3.7

Phusion Passenger allows remote attackers to spoof headers

CVE-2015-7519GHSA-fxwv-953p-7qpf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (passenger 5.0.22, 4.0.60), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems passenger

    Affected
    < 4.0.60>= 5.0.0, < 5.0.22
    Fixed in
    4.0.60, 5.0.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2015-7519: 2.36% estimated exploitation activity in the next 30 days; percentile 83.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an XUser header.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fxwv-953p-7qpf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-7519

Advisory: Phusion Passenger allows remote attackers to spoof headers
IDs: CVE-2015-7519, GHSA-fxwv-953p-7qpf
Record: https://patchnext.com/advisories/cve-2015-7519 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: passenger 5.0.22, 4.0.60. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems passenger: affected < 4.0.60; >= 5.0.0, < 5.0.22; fixed in 4.0.60, 5.0.22

## Suggested inspection (read-only)
- RubyGems passenger: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on passenger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fxwv-953p-7qpf (GitHub-reviewed advisory GHSA-fxwv-953p-7qpf lists affected ranges: RubyGems passenger >=0 =5.0.0 <5.0.22)

Commands are suggestions: review each one before running it.

Loading voting…