Skip to content

← Actionable
Unrated

Heap-based buffer overflow in nokogiri

CVE-2015-7499GHSA-jxjr-5h69-qw3w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.6.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems nokogiri

    Affected
    >= 1.6.0, <= 1.6.7.1
    Fixed in
    1.6.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-7499: 6.41% estimated exploitation activity in the next 30 days; percentile 93.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Heap-based buffer overflow in the xmlGROW function in parser.c in libxml2 before 2.9.3. A remote attacker could provide a specially crafted XML or HTML file that, when processed by an application using libxml2, would cause that application to use an excessive amount of CPU, leak potentially sensitive information, or crash the application.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jxjr-5h69-qw3w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-7499

Advisory: Heap-based buffer overflow in nokogiri
IDs: CVE-2015-7499, GHSA-jxjr-5h69-qw3w
Record: https://patchnext.com/advisories/cve-2015-7499 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.6.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems nokogiri: affected >= 1.6.0, <= 1.6.7.1; fixed in 1.6.7.2

## Suggested inspection (read-only)
- RubyGems nokogiri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nokogiri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jxjr-5h69-qw3w (GitHub-reviewed advisory GHSA-jxjr-5h69-qw3w lists affected ranges: RubyGems nokogiri >=1.6.0 <=1.6.7.1)

Commands are suggestions: review each one before running it.

Loading voting…