Plone Cross-site Scripting Vulnerability
CVE-2015-7316GHSA-vf8g-m3vq-6p4p
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI plone
- Affected
- >= 5.0rc1, <= 5.0rc1>= 3.3, <= 3.3.6>= 4.0, <= 4.0.10>= 4.1, <= 4.1.6>= 4.2, <= 4.2.7>= 4.3, < 4.3.7
- Fixed in
- 3.3.7, 4.2.8, 4.0.11, 4.3.7, 4.1.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vf8g-m3vq-6p4p lists affected ranges: PyPI plone >=3.3 =4.0 =4.1 =4.2 =4.3 <4.3.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf8g-m3vq-6p4p lists affected ranges: PyPI plone >=5.0rc1 =3.3 =4.0 =4.1 =4.2 =4.3 <4.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2015-7316: 1.42% estimated exploitation activity in the next 30 days; percentile 72.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Plone's URL checking infrastructure includes a method for checking if URLs valid and located in the Plone site. By passing HTML into a specially crafted url containing <script, %3Cscript, javascript:, or javascript%3A, Cross-site Scripting can be achieved.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vf8g-m3vq-6p4p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vf8g-m3vq-6p4p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-7316 Advisory: Plone Cross-site Scripting Vulnerability IDs: CVE-2015-7316, GHSA-vf8g-m3vq-6p4p Record: https://patchnext.com/advisories/cve-2015-7316 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: plone 4.3.7, 4.2.8, 4.1.7, 4.0.11, 3.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI plone: affected >= 5.0rc1, <= 5.0rc1; >= 3.3, <= 3.3.6; >= 4.0, <= 4.0.10; >= 4.1, <= 4.1.6; >= 4.2, <= 4.2.7; >= 4.3, < 4.3.7; fixed in 3.3.7, 4.2.8, 4.0.11, 4.3.7, 4.1.7 ## Suggested inspection (read-only) - `python -m pip show plone`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on plone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vf8g-m3vq-6p4p (OSV record GHSA-vf8g-m3vq-6p4p lists affected ranges: PyPI plone >=3.3 =4.0 =4.1 =4.2 =4.3 <4.3.7 (fixed)) - Verified: https://github.com/advisories/GHSA-vf8g-m3vq-6p4p (GitHub-reviewed advisory GHSA-vf8g-m3vq-6p4p lists affected ranges: PyPI plone >=5.0rc1 =3.3 =4.0 =4.1 =4.2 =4.3 <4.3.7) Commands are suggestions: review each one before running it.
Loading voting…