Plone unauthorized member addition vulnerability
CVE-2015-7315GHSA-984m-rj28-8c6x
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI products-cmfplone
- Affected
- >= 3.3.0, < 4.3.7>= 5.0a1, < 5.0rc2
- Fixed in
- 4.3.7, 5.0rc2
PyPI plone
- Affected
- >= 3.3, <= 3.3.6>= 4.0a1, <= 4.0.10>= 4.1a1, <= 4.1.6>= 4.2a1, <= 4.2.7>= 4.3a1, <= 4.3.6
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-984m-rj28-8c6x lists affected ranges: PyPI products-cmfplone >=3.3.0 =5.0a1 =3.3 =4.0a1 =4.1a1 =4.2a1 =4.3a1 <=4.3.6
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2015-7315: 2.02% estimated exploitation activity in the next 30 days; percentile 80.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.0 through 4.3.6, and 5.0rc1 allows remote attackers to add a new member to a Plone site with registration enabled, without acknowledgment of site administrator.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-984m-rj28-8c6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-7315 Advisory: Plone unauthorized member addition vulnerability IDs: CVE-2015-7315, GHSA-984m-rj28-8c6x Record: https://patchnext.com/advisories/cve-2015-7315 (revision 2, source checked 25 Oct 2026, 01:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: products-cmfplone 5.0rc2, 4.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI products-cmfplone: affected >= 3.3.0, < 4.3.7; >= 5.0a1, < 5.0rc2; fixed in 4.3.7, 5.0rc2 - PyPI plone: affected >= 3.3, <= 3.3.6; >= 4.0a1, <= 4.0.10; >= 4.1a1, <= 4.1.6; >= 4.2a1, <= 4.2.7; >= 4.3a1, <= 4.3.6 ## Suggested inspection (read-only) - `python -m pip show products-cmfplone`: prints the installed version. Run with the environment that serves production active. - `python -m pip show plone`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on products-cmfplone, plone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-984m-rj28-8c6x (OSV record GHSA-984m-rj28-8c6x lists affected ranges: PyPI products-cmfplone >=3.3.0 =5.0a1 =3.3 =4.0a1 =4.1a1 =4.2a1 =4.3a1 <=4.3.6) Commands are suggestions: review each one before running it.
Loading voting…