Skip to content

← Actionable
Critical, CVSS 9.8amended

salt password information leaked in debug logs

CVE-2015-6941GHSA-cxm4-7qcw-267r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (salt 2015.8.1, 2015.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI salt

    Affected
    >= 2015.5, < 2015.5.6>= 2015.8, < 2015.8.1
    Fixed in
    2015.5.6, 2015.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-6941: 2.83% estimated exploitation activity in the next 30 days; percentile 86.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

winuseradd, salt-cloud and the Linode driver in salt 2015.5.x before 2015.5.6, and 2015.8.x before 2015.8.1 leak password information in debug logs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cxm4-7qcw-267r

  2. Revision 1 · created ·

    Published from osv record GHSA-cxm4-7qcw-267r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-6941

Advisory: salt password information leaked in debug logs
IDs: CVE-2015-6941, GHSA-cxm4-7qcw-267r
Record: https://patchnext.com/advisories/cve-2015-6941 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: salt 2015.8.1, 2015.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI salt: affected >= 2015.5, < 2015.5.6; >= 2015.8, < 2015.8.1; fixed in 2015.5.6, 2015.8.1

## Suggested inspection (read-only)
- `python -m pip show salt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on salt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cxm4-7qcw-267r (OSV record GHSA-cxm4-7qcw-267r lists affected ranges: PyPI salt >=2015.5 =2015.8 <2015.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cxm4-7qcw-267r (GitHub-reviewed advisory GHSA-cxm4-7qcw-267r lists affected ranges: PyPI salt >=2015.5 =2015.8 <2015.8.1)

Commands are suggestions: review each one before running it.

Loading voting…