Skip to content

← Actionable
Critical, CVSS 9.8

Yii2 allows attackers to execute any local .php file via a relative path in the view parameter

CVE-2015-5467GHSA-7cfq-72w2-24q4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii2 2.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist yiisoft/yii2

    Affected
    >= 2.0.0, < 2.0.5
    Fixed in
    2.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-5467: 0.88% estimated exploitation activity in the next 30 days; percentile 59.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

web\ViewAction in Yii (aka Yii2) 2.x before 2.0.5 allows attackers to execute any local .php file via a relative path in the view parameeter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7cfq-72w2-24q4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-5467

Advisory: Yii2 allows attackers to execute any local .php file via a relative path in the view parameter
IDs: CVE-2015-5467, GHSA-7cfq-72w2-24q4
Record: https://patchnext.com/advisories/cve-2015-5467 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii2 2.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yiisoft/yii2: affected >= 2.0.0, < 2.0.5; fixed in 2.0.5

## Suggested inspection (read-only)
- Packagist yiisoft/yii2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yiisoft/yii2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7cfq-72w2-24q4 (GitHub-reviewed advisory GHSA-7cfq-72w2-24q4 lists affected ranges: Packagist yiisoft/yii2 >=2.0.0 <2.0.5)

Commands are suggestions: review each one before running it.

Loading voting…