Skip to content

← Actionable
Critical, CVSS 9.2amended

Injection vulnerability that affects ironic-discoverd

CVE-2015-5306GHSA-x64g-wjmw-w328

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-ironic-inspector-client 0.2.5; ironic-inspector 2.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2015-5306: 1.60% estimated exploitation activity in the next 30 days; percentile 75.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenStack Ironic Inspector (aka ironic-inspector or ironic-discoverd), when debug mode is enabled, might allow remote attackers to access the Flask console and execute arbitrary Python code by triggering an error.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x64g-wjmw-w328

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x64g-wjmw-w328

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-5306

Advisory: Injection vulnerability that affects ironic-discoverd
IDs: CVE-2015-5306, GHSA-x64g-wjmw-w328
Record: https://patchnext.com/advisories/cve-2015-5306 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-ironic-inspector-client 0.2.5; ironic-inspector 2.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-ironic-inspector-client: affected < 0.2.5; fixed in 0.2.5
- PyPI ironic-inspector: affected < 2.2.2; fixed in 2.2.2

## Suggested inspection (read-only)
- `python -m pip show python-ironic-inspector-client`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show ironic-inspector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-ironic-inspector-client, ironic-inspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x64g-wjmw-w328 (OSV record GHSA-x64g-wjmw-w328 lists affected ranges: PyPI python-ironic-inspector-client >=0 =0 <2.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-x64g-wjmw-w328 (GitHub-reviewed advisory GHSA-x64g-wjmw-w328 lists affected ranges: PyPI python-ironic-inspector-client >=0 =0 <2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…