TripleO Heat templates might allow remote attackers to obtain sensitive information from private containers
CVE-2015-5271GHSA-8936-44gw-7664
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tripleo-heat-templates 0.8.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.8.7
- Fixed in
- 0.8.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8936-44gw-7664 lists affected ranges: PyPI tripleo-heat-templates >=0 <0.8.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8936-44gw-7664 lists affected ranges: PyPI tripleo-heat-templates >=0 <0.8.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2015-5271: 2.44% estimated exploitation activity in the next 30 days; percentile 84.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The TripleO Heat templates (tripleo-heat-templates) do not properly order the Identity Service (keystone) before the OpenStack Object Storage (Swift) staticweb middleware in the swiftproxy pipeline when the staticweb middleware is enabled, which might allow remote attackers to obtain sensitive information from private containers via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8936-44gw-7664
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8936-44gw-7664
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-5271 Advisory: TripleO Heat templates might allow remote attackers to obtain sensitive information from private containers IDs: CVE-2015-5271, GHSA-8936-44gw-7664 Record: https://patchnext.com/advisories/cve-2015-5271 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tripleo-heat-templates 0.8.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tripleo-heat-templates: affected < 0.8.7; fixed in 0.8.7 ## Suggested inspection (read-only) - `python -m pip show tripleo-heat-templates`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tripleo-heat-templates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8936-44gw-7664 (OSV record GHSA-8936-44gw-7664 lists affected ranges: PyPI tripleo-heat-templates >=0 <0.8.7 (fixed)) - Verified: https://github.com/advisories/GHSA-8936-44gw-7664 (GitHub-reviewed advisory GHSA-8936-44gw-7664 lists affected ranges: PyPI tripleo-heat-templates >=0 <0.8.7) Commands are suggestions: review each one before running it.
Loading voting…