Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenStack Image Service (Glance) allows remote authenticated users to bypass access restrictions

CVE-2015-5251GHSA-q748-mcwg-xmqv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glance 2015.1.2, 2014.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI glance

    Affected
    >= 2015.1.0, < 2015.1.2>= 2011.2, < 2014.2.4
    Fixed in
    2015.1.2, 2014.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2015-5251: 2.05% estimated exploitation activity in the next 30 days; percentile 81.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenStack Image Service (Glance) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) allow remote authenticated users to change the status of their images and bypass access restrictions via the HTTP x-image-meta-status header to images/.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q748-mcwg-xmqv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q748-mcwg-xmqv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-5251

Advisory: OpenStack Image Service (Glance) allows remote authenticated users to bypass access restrictions
IDs: CVE-2015-5251, GHSA-q748-mcwg-xmqv
Record: https://patchnext.com/advisories/cve-2015-5251 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glance 2015.1.2, 2014.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI glance: affected >= 2015.1.0, < 2015.1.2; >= 2011.2, < 2014.2.4; fixed in 2015.1.2, 2014.2.4

## Suggested inspection (read-only)
- `python -m pip show glance`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glance.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q748-mcwg-xmqv (OSV record GHSA-q748-mcwg-xmqv lists affected ranges: PyPI glance >=2011.2 =2015.1.0 <2015.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-q748-mcwg-xmqv (GitHub-reviewed advisory GHSA-q748-mcwg-xmqv lists affected ranges: PyPI glance >=2015.1.0 =2011.2 <2014.2.4)

Commands are suggestions: review each one before running it.

Loading voting…