Skip to content

← Actionable
Critical, CVSS 9.8

phpWhois arbitrary code execution via a crafted whois record

CVE-2015-5243GHSA-c95f-27gx-6vq9

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist jsmitty12/phpwhois

    Affected
    < 5.1.0
    Fixed in
    5.1.0
  • Packagist kazist/phpwhois

    Affected
    <= 4.2.6
    Fixed in
    no fixed version recorded
  • Packagist truckersmp/phpwhois

    Affected
    <= 4.3.1
    Fixed in
    no fixed version recorded
  • Packagist ivankristianto/phpwhois

    Affected
    <= 4.3.0
    Fixed in
    no fixed version recorded
  • Packagist serluck/phpwhois

    Affected
    <= 4.2.6
    Fixed in
    no fixed version recorded
  • Packagist brightlocal/phpwhois

    Affected
    <= 4.2.5
    Fixed in
    no fixed version recorded
  • Packagist simple-updates/phpwhois

    Affected
    <= 1.0.0
    Fixed in
    no fixed version recorded
  • Packagist phpwhois/phpwhois

    Affected
    <= 4.2.5
    Fixed in
    no fixed version recorded
  • Packagist david-garcia/phpwhois

    Affected
    <= 4.3.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-5243: 6.19% estimated exploitation activity in the next 30 days; percentile 93.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

phpWhois allows remote attackers to execute arbitrary code via a crafted whois record.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c95f-27gx-6vq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-5243

Advisory: phpWhois arbitrary code execution via a crafted whois record
IDs: CVE-2015-5243, GHSA-c95f-27gx-6vq9
Record: https://patchnext.com/advisories/cve-2015-5243 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: jsmitty12/phpwhois 5.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist jsmitty12/phpwhois: affected < 5.1.0; fixed in 5.1.0
- Packagist kazist/phpwhois: affected <= 4.2.6
- Packagist truckersmp/phpwhois: affected <= 4.3.1
- Packagist ivankristianto/phpwhois: affected <= 4.3.0
- Packagist serluck/phpwhois: affected <= 4.2.6
- Packagist brightlocal/phpwhois: affected <= 4.2.5
- Packagist simple-updates/phpwhois: affected <= 1.0.0
- Packagist phpwhois/phpwhois: affected <= 4.2.5
- Packagist david-garcia/phpwhois: affected <= 4.3.1

## Suggested inspection (read-only)
- Packagist jsmitty12/phpwhois: check the installed version with your package manager.
- Packagist kazist/phpwhois: check the installed version with your package manager.
- Packagist truckersmp/phpwhois: check the installed version with your package manager.
- Packagist ivankristianto/phpwhois: check the installed version with your package manager.
- Packagist serluck/phpwhois: check the installed version with your package manager.
- Packagist brightlocal/phpwhois: check the installed version with your package manager.
- Packagist simple-updates/phpwhois: check the installed version with your package manager.
- Packagist phpwhois/phpwhois: check the installed version with your package manager.
- Packagist david-garcia/phpwhois: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsmitty12/phpwhois, kazist/phpwhois, truckersmp/phpwhois, ivankristianto/phpwhois, serluck/phpwhois, brightlocal/phpwhois, simple-updates/phpwhois, phpwhois/phpwhois, david-garcia/phpwhois.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c95f-27gx-6vq9 (GitHub-reviewed advisory GHSA-c95f-27gx-6vq9 lists affected ranges: Packagist jsmitty12/phpwhois >=0 =0 =0 =0 =0 =0 =0 =0 =0 <=4.3.1)

Commands are suggestions: review each one before running it.

Loading voting…