Information Exposure in Docker Engine
CVE-2015-3630GHSA-8fvr-5rqf-3wwh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.6.0, < 1.6.1
- Fixed in
- 1.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8fvr-5rqf-3wwh lists affected ranges: Go github.com/docker/docker >=1.6.0 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2015-3630: 0.55% estimated exploitation activity in the next 30 days; percentile 45.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Docker Engine before 1.6.1 uses weak permissions for (1) /proc/asound, (2) /proc/timerstats, (3) /proc/latencystats, and (4) /proc/fs, which allows local users to modify the host, obtain sensitive information, and perform protocol downgrade attacks via a crafted image.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8fvr-5rqf-3wwh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-3630 Advisory: Information Exposure in Docker Engine IDs: CVE-2015-3630, GHSA-8fvr-5rqf-3wwh Record: https://patchnext.com/advisories/cve-2015-3630 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/docker/docker: affected >= 1.6.0, < 1.6.1; fixed in 1.6.1 ## Suggested inspection (read-only) - Go github.com/docker/docker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/docker/docker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8fvr-5rqf-3wwh (GitHub-reviewed advisory GHSA-8fvr-5rqf-3wwh lists affected ranges: Go github.com/docker/docker >=1.6.0 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…