Web Console (Ruby gem) contains whitelisted_ips bypass
CVE-2015-3224GHSA-67j6-xv27-w6ww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-console 2.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems web-console
- Affected
- < 2.1.3
- Fixed in
- 2.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-67j6-xv27-w6ww lists affected ranges: RubyGems web-console >=0 <2.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-3224: 49.09% estimated exploitation activity in the next 30 days; percentile 98.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
request.rb in Web Console before 2.1.3, as used with Ruby on Rails 3.x and 4.x, does not properly restrict the use of X-Forwarded-For headers in determining a client's IP address, which allows remote attackers to bypass the whitelistedips protection mechanism via a crafted request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-67j6-xv27-w6ww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-3224 Advisory: Web Console (Ruby gem) contains whitelisted_ips bypass IDs: CVE-2015-3224, GHSA-67j6-xv27-w6ww Record: https://patchnext.com/advisories/cve-2015-3224 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: web-console 2.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems web-console: affected < 2.1.3; fixed in 2.1.3 ## Suggested inspection (read-only) - RubyGems web-console: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on web-console. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-67j6-xv27-w6ww (GitHub-reviewed advisory GHSA-67j6-xv27-w6ww lists affected ranges: RubyGems web-console >=0 <2.1.3) Commands are suggestions: review each one before running it.
Loading voting…