OpenStack Neutron Improper Input Validation vulnerability
CVE-2015-3221GHSA-wf44-4mgj-rwvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neutron 2015.1.1, 2014.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI neutron
- Affected
- >= 2015.1.0, < 2015.1.1>= 2000, < 2014.2.4
- Fixed in
- 2014.2.4, 2015.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wf44-4mgj-rwvx lists affected ranges: PyPI neutron >=2000 =2015.1.0 <2015.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wf44-4mgj-rwvx lists affected ranges: PyPI neutron >=2015.1.0 =2000 <2014.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-3221: 11.43% estimated exploitation activity in the next 30 days; percentile 96.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenStack Neutron before 2014.2.4 (juno) and 2015.1.x before 2015.1.1 (kilo), when using the IPTables firewall driver, allows remote authenticated users to cause a denial of service (L2 agent crash) by adding an address pair that is rejected by the ipset tool.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wf44-4mgj-rwvx
- Revision 1 · created ·
Published from osv record GHSA-wf44-4mgj-rwvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-3221 Advisory: OpenStack Neutron Improper Input Validation vulnerability IDs: CVE-2015-3221, GHSA-wf44-4mgj-rwvx Record: https://patchnext.com/advisories/cve-2015-3221 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neutron 2015.1.1, 2014.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI neutron: affected >= 2015.1.0, < 2015.1.1; >= 2000, < 2014.2.4; fixed in 2014.2.4, 2015.1.1 ## Suggested inspection (read-only) - `python -m pip show neutron`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neutron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wf44-4mgj-rwvx (OSV record GHSA-wf44-4mgj-rwvx lists affected ranges: PyPI neutron >=2000 =2015.1.0 <2015.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-wf44-4mgj-rwvx (GitHub-reviewed advisory GHSA-wf44-4mgj-rwvx lists affected ranges: PyPI neutron >=2015.1.0 =2000 <2014.2.4) Commands are suggestions: review each one before running it.
Loading voting…