tlslite remote denial of service vulnerability
CVE-2015-3220GHSA-4749-p7rx-8jjj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tlslite 0.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tlslite
- Affected
- < 0.4.9
- Fixed in
- 0.4.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4749-p7rx-8jjj lists affected ranges: PyPI tlslite >=0 <0.4.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4749-p7rx-8jjj lists affected ranges: PyPI tlslite >=0 <0.4.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2015-3220: 3.23% estimated exploitation activity in the next 30 days; percentile 88.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4749-p7rx-8jjj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4749-p7rx-8jjj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-3220 Advisory: tlslite remote denial of service vulnerability IDs: CVE-2015-3220, GHSA-4749-p7rx-8jjj Record: https://patchnext.com/advisories/cve-2015-3220 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tlslite 0.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tlslite: affected < 0.4.9; fixed in 0.4.9 ## Suggested inspection (read-only) - `python -m pip show tlslite`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tlslite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4749-p7rx-8jjj (OSV record GHSA-4749-p7rx-8jjj lists affected ranges: PyPI tlslite >=0 <0.4.9 (fixed)) - Verified: https://github.com/advisories/GHSA-4749-p7rx-8jjj (GitHub-reviewed advisory GHSA-4749-p7rx-8jjj lists affected ranges: PyPI tlslite >=0 <0.4.9) Commands are suggestions: review each one before running it.
Loading voting…