Skip to content

← Actionable
Critical, CVSS 9.2amended

python-kerberos vulnerable to KDC spoofing attacks

CVE-2015-3206GHSA-mffc-9gx5-99g3

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI kerberos

    Affected
    <= 1.2.5
    Fixed in
    no fixed version recorded
  • PyPI pykerberos

    Affected
    < 1.1.6
    Fixed in
    1.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2015-3206: 2.39% estimated exploitation activity in the next 30 days; percentile 83.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The checkPassword function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers to cause a denial of service (bad response), or have other unspecified impact by performing a man-in-the-middle attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mffc-9gx5-99g3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mffc-9gx5-99g3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-3206

Advisory: python-kerberos vulnerable to KDC spoofing attacks
IDs: CVE-2015-3206, GHSA-mffc-9gx5-99g3
Record: https://patchnext.com/advisories/cve-2015-3206 (revision 3, source checked 26 Oct 2026, 13:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: pykerberos 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI kerberos: affected <= 1.2.5
- PyPI pykerberos: affected < 1.1.6; fixed in 1.1.6

## Suggested inspection (read-only)
- `python -m pip show kerberos`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show pykerberos`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kerberos, pykerberos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mffc-9gx5-99g3 (OSV record GHSA-mffc-9gx5-99g3 lists affected ranges: PyPI kerberos >=0 =0 <1.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-mffc-9gx5-99g3 (GitHub-reviewed advisory GHSA-mffc-9gx5-99g3 lists affected ranges: PyPI kerberos >=0 =0 <1.1.6)

Commands are suggestions: review each one before running it.

Loading voting…