ceph-deploy allows local users to obtain sensitive information by reading the file
CVE-2015-3010GHSA-9w4f-3v37-6f75
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ceph-deploy 1.5.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ceph-deploy
- Affected
- < 1.5.23
- Fixed in
- 1.5.23
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9w4f-3v37-6f75 lists affected ranges: PyPI ceph-deploy >=0 <1.5.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9w4f-3v37-6f75 lists affected ranges: PyPI ceph-deploy >=0 <1.5.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.2 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2015-3010: 0.38% estimated exploitation activity in the next 30 days; percentile 31.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ceph-deploy before 1.5.23 uses weak permissions (644) for ceph/ceph.client.admin.keyring, which allows local users to obtain sensitive information by reading the file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9w4f-3v37-6f75
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9w4f-3v37-6f75
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-3010 Advisory: ceph-deploy allows local users to obtain sensitive information by reading the file IDs: CVE-2015-3010, GHSA-9w4f-3v37-6f75 Record: https://patchnext.com/advisories/cve-2015-3010 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ceph-deploy 1.5.23. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ceph-deploy: affected < 1.5.23; fixed in 1.5.23 ## Suggested inspection (read-only) - `python -m pip show ceph-deploy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ceph-deploy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9w4f-3v37-6f75 (OSV record GHSA-9w4f-3v37-6f75 lists affected ranges: PyPI ceph-deploy >=0 <1.5.23 (fixed)) - Verified: https://github.com/advisories/GHSA-9w4f-3v37-6f75 (GitHub-reviewed advisory GHSA-9w4f-3v37-6f75 lists affected ranges: PyPI ceph-deploy >=0 <1.5.23) Commands are suggestions: review each one before running it.
Loading voting…