Skip to content

← Actionable
Unrated

Symfony Vulnerable to PHP Eval Injection

CVE-2015-2308GHSA-5c58-w9xc-qcj9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.6.6, 2.5.11, 2.3.27; symfony/http-kernel 2.6.6, 2.5.11, 2.3.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.0.0, < 2.3.27>= 2.4.0, < 2.5.11>= 2.6.0, < 2.6.6
    Fixed in
    2.3.27, 2.5.11, 2.6.6
  • Packagist symfony/http-kernel

    Affected
    >= 2.0.0, < 2.3.27>= 2.4.0, < 2.5.11>= 2.6.0, < 2.6.6
    Fixed in
    2.3.27, 2.5.11, 2.6.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-2308: 1.34% estimated exploitation activity in the next 30 days; percentile 71.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Applications with ESI support (and SSI support as of Symfony 2.6) enabled and using the Symfony built-in reverse proxy (the Symfony\Component\HttpKernel\HttpCache class) are vulnerable to PHP code injection; a malicious user can inject PHP code that will be executed by the server. HttpCache uses eval() to execute files in its cache when they contain ESI tags (and only when ESI is enabled). The vulnerability comes from the fact that PHP allows contents of <script language="php" tags to be executed (and this kind of PHP tags is always available regardless of the configuration), but there were not escaped before the evaluation. A possible exploit comes from websites also vulnerable to Cross-Site Scripting as an attacker can successfully conduct a PHP code injection attack by passing such a tag in a user submitted variable (for which proper output escaping was not applied).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5c58-w9xc-qcj9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-2308

Advisory: Symfony Vulnerable to PHP Eval Injection
IDs: CVE-2015-2308, GHSA-5c58-w9xc-qcj9
Record: https://patchnext.com/advisories/cve-2015-2308 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.6.6, 2.5.11, 2.3.27; symfony/http-kernel 2.6.6, 2.5.11, 2.3.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.0.0, < 2.3.27; >= 2.4.0, < 2.5.11; >= 2.6.0, < 2.6.6; fixed in 2.3.27, 2.5.11, 2.6.6
- Packagist symfony/http-kernel: affected >= 2.0.0, < 2.3.27; >= 2.4.0, < 2.5.11; >= 2.6.0, < 2.6.6; fixed in 2.3.27, 2.5.11, 2.6.6

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/http-kernel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/http-kernel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5c58-w9xc-qcj9 (GitHub-reviewed advisory GHSA-5c58-w9xc-qcj9 lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.4.0 =2.6.0 =2.0.0 =2.4.0 =2.6.0 <2.6.6)

Commands are suggestions: review each one before running it.

Loading voting…