Python Requests Session Fixation
CVE-2015-2296GHSA-pg2w-x9wp-vw92
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (requests 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI requests
- Affected
- >= 2.1.0, < 2.6.0
- Fixed in
- 2.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pg2w-x9wp-vw92 lists affected ranges: PyPI requests >=2.1.0 <2.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg2w-x9wp-vw92 lists affected ranges: PyPI requests >=2.1.0 <2.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-2296: 3.18% estimated exploitation activity in the next 30 days; percentile 88.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The resolveredirects function in sessions.py in requests 2.1.0 through 2.5.3 allows remote attackers to conduct session fixation attacks via a cookie without a host value in a redirect.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pg2w-x9wp-vw92
- Revision 1 · created ·
Published from osv record GHSA-pg2w-x9wp-vw92
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-2296 Advisory: Python Requests Session Fixation IDs: CVE-2015-2296, GHSA-pg2w-x9wp-vw92 Record: https://patchnext.com/advisories/cve-2015-2296 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: requests 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI requests: affected >= 2.1.0, < 2.6.0; fixed in 2.6.0 ## Suggested inspection (read-only) - `python -m pip show requests`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on requests. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pg2w-x9wp-vw92 (OSV record GHSA-pg2w-x9wp-vw92 lists affected ranges: PyPI requests >=2.1.0 <2.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pg2w-x9wp-vw92 (GitHub-reviewed advisory GHSA-pg2w-x9wp-vw92 lists affected ranges: PyPI requests >=2.1.0 <2.6.0) Commands are suggestions: review each one before running it.
Loading voting…