Moodle XSS Vulnerability
CVE-2015-2269GHSA-cp39-43xr-2wrp
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- <= 2.5.9>= 2.6.0, < 2.6.9>= 2.7.0, < 2.7.6>= 2.8.0, < 2.8.4
- Fixed in
- 2.6.9, 2.7.6, 2.8.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cp39-43xr-2wrp lists affected ranges: Packagist moodle/moodle >=0 =2.6.0 =2.7.0 =2.8.0 <2.8.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-2269: 3.26% estimated exploitation activity in the next 30 days; percentile 88.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cp39-43xr-2wrp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-2269 Advisory: Moodle XSS Vulnerability IDs: CVE-2015-2269, GHSA-cp39-43xr-2wrp Record: https://patchnext.com/advisories/cve-2015-2269 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: moodle/moodle 2.8.4, 2.7.6, 2.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected <= 2.5.9; >= 2.6.0, < 2.6.9; >= 2.7.0, < 2.7.6; >= 2.8.0, < 2.8.4; fixed in 2.6.9, 2.7.6, 2.8.4 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cp39-43xr-2wrp (GitHub-reviewed advisory GHSA-cp39-43xr-2wrp lists affected ranges: Packagist moodle/moodle >=0 =2.6.0 =2.7.0 =2.8.0 <2.8.4) Commands are suggestions: review each one before running it.
Loading voting…