Slim vulnerable to PHP object injection
CVE-2015-2171GHSA-74mf-vjpg-9xh7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (slim/slim 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist slim/slim
- Affected
- < 2.6.0
- Fixed in
- 2.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74mf-vjpg-9xh7 lists affected ranges: Packagist slim/slim >=0 <2.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-2171: 2.50% estimated exploitation activity in the next 30 days; percentile 84.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-74mf-vjpg-9xh7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-2171 Advisory: Slim vulnerable to PHP object injection IDs: CVE-2015-2171, GHSA-74mf-vjpg-9xh7 Record: https://patchnext.com/advisories/cve-2015-2171 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: slim/slim 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist slim/slim: affected < 2.6.0; fixed in 2.6.0 ## Suggested inspection (read-only) - Packagist slim/slim: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on slim/slim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-74mf-vjpg-9xh7 (GitHub-reviewed advisory GHSA-74mf-vjpg-9xh7 lists affected ranges: Packagist slim/slim >=0 <2.6.0) Commands are suggestions: review each one before running it.
Loading voting…