Improper Limitation of a Pathname to a Restricted Directory in Apache ActiveMQ
CVE-2015-1830GHSA-3v63-f83x-37x4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-client 5.11.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-client
- Affected
- >= 5.0.0, <= 5.11.1
- Fixed in
- 5.11.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3v63-f83x-37x4 lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <=5.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-1830: 84.41% estimated exploitation activity in the next 30 days; percentile 99.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory traversal vulnerability in the fileserver upload/download functionality for blob messages in Apache ActiveMQ 5.x before 5.11.2 for Windows allows remote attackers to create JSP files in arbitrary directories via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3v63-f83x-37x4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-1830 Advisory: Improper Limitation of a Pathname to a Restricted Directory in Apache ActiveMQ IDs: CVE-2015-1830, GHSA-3v63-f83x-37x4 Record: https://patchnext.com/advisories/cve-2015-1830 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-client 5.11.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-client: affected >= 5.0.0, <= 5.11.1; fixed in 5.11.2 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3v63-f83x-37x4 (GitHub-reviewed advisory GHSA-3v63-f83x-37x4 lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <=5.11.1) Commands are suggestions: review each one before running it.
Loading voting…