Improper Certificate Validation in Shibboleth Identity Provider and OpenSAML
CVE-2015-1796GHSA-78fq-w796-q537
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (edu.internet2.middleware:shibboleth-identityprovider 2.4.4; org.opensaml:opensaml 2.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven edu.internet2.middleware:shibboleth-identityprovider
- Affected
- <= 2.4.3
- Fixed in
- 2.4.4
Maven org.opensaml:opensaml
- Affected
- <= 2.6.4
- Fixed in
- 2.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-78fq-w796-q537 lists affected ranges: Maven org.opensaml:opensaml >=0 =0 <=2.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-1796: 1.25% estimated exploitation activity in the next 30 days; percentile 69.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The PKIX trust engines in Shibboleth Identity Provider before 2.4.4 and OpenSAML Java (OpenSAML-J) before 2.6.5 trust candidate X.509 credentials when no trusted names are available for the entityID, which allows remote attackers to impersonate an entity via a certificate issued by a shibmd:KeyAuthority trust anchor.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-78fq-w796-q537
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-1796 Advisory: Improper Certificate Validation in Shibboleth Identity Provider and OpenSAML IDs: CVE-2015-1796, GHSA-78fq-w796-q537 Record: https://patchnext.com/advisories/cve-2015-1796 (revision 1, source checked 26 Oct 2026, 15:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: edu.internet2.middleware:shibboleth-identityprovider 2.4.4; org.opensaml:opensaml 2.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven edu.internet2.middleware:shibboleth-identityprovider: affected <= 2.4.3; fixed in 2.4.4 - Maven org.opensaml:opensaml: affected <= 2.6.4; fixed in 2.6.5 ## Suggested inspection (read-only) - Maven edu.internet2.middleware:shibboleth-identityprovider: check the installed version with your package manager. - Maven org.opensaml:opensaml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on edu.internet2.middleware:shibboleth-identityprovider, org.opensaml:opensaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-78fq-w796-q537 (GitHub-reviewed advisory GHSA-78fq-w796-q537 lists affected ranges: Maven org.opensaml:opensaml >=0 =0 <=2.4.3) Commands are suggestions: review each one before running it.
Loading voting…