Zend Framework CSRF Vulnerability
CVE-2015-1786GHSA-gwwq-54qp-9pgp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework 2.3.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework
- Affected
- >= 2.3.0, < 2.3.6
- Fixed in
- 2.3.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwwq-54qp-9pgp lists affected ranges: Packagist zendframework/zendframework >=2.3.0 <2.3.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2015-1786: 0.66% estimated exploitation activity in the next 30 days; percentile 51.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gwwq-54qp-9pgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-1786 Advisory: Zend Framework CSRF Vulnerability IDs: CVE-2015-1786, GHSA-gwwq-54qp-9pgp Record: https://patchnext.com/advisories/cve-2015-1786 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework 2.3.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework: affected >= 2.3.0, < 2.3.6; fixed in 2.3.6 ## Suggested inspection (read-only) - Packagist zendframework/zendframework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gwwq-54qp-9pgp (GitHub-reviewed advisory GHSA-gwwq-54qp-9pgp lists affected ranges: Packagist zendframework/zendframework >=2.3.0 <2.3.6) Commands are suggestions: review each one before running it.
Loading voting…