Centreon Command Injection
CVE-2015-1561GHSA-c4fj-3wqq-g9c9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (centreon/centreon 2.8.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist centreon/centreon
- Affected
- < 2.8.28
- Fixed in
- 2.8.28
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c4fj-3wqq-g9c9 lists affected ranges: Packagist centreon/centreon >=0 <2.8.28
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2015-1561: 8.27% estimated exploitation activity in the next 30 days; percentile 94.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The escapecommand function in include/Administration/corePerformance/getStats.php in Centreon (formerly Merethis Centreon) 2.5.4 and earlier (offending file deleted in Centreon 19.10.0) uses an incorrect regular expression, which allows remote authenticated users to execute arbitrary commands via shell metacharacters in the nsid parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c4fj-3wqq-g9c9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-1561 Advisory: Centreon Command Injection IDs: CVE-2015-1561, GHSA-c4fj-3wqq-g9c9 Record: https://patchnext.com/advisories/cve-2015-1561 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: centreon/centreon 2.8.28. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist centreon/centreon: affected < 2.8.28; fixed in 2.8.28 ## Suggested inspection (read-only) - Packagist centreon/centreon: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on centreon/centreon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c4fj-3wqq-g9c9 (GitHub-reviewed advisory GHSA-c4fj-3wqq-g9c9 lists affected ranges: Packagist centreon/centreon >=0 <2.8.28) Commands are suggestions: review each one before running it.
Loading voting…