Puppet Labs Facter allows local users to obtain sensitive Amazon EC2 IAM instance metadata
CVE-2015-1426GHSA-j436-h7hm-rx46
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (facter 2.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems facter
- Affected
- >= 1.6.0, < 2.4.1
- Fixed in
- 2.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j436-h7hm-rx46 lists affected ranges: RubyGems facter >=1.6.0 <2.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-1426: 0.36% estimated exploitation activity in the next 30 days; percentile 29.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Puppet Labs Facter 1.6.0 through 2.4.0 allows local users to obtains sensitive Amazon EC2 IAM instance metadata by reading a fact for an Amazon EC2 node.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j436-h7hm-rx46
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-1426 Advisory: Puppet Labs Facter allows local users to obtain sensitive Amazon EC2 IAM instance metadata IDs: CVE-2015-1426, GHSA-j436-h7hm-rx46 Record: https://patchnext.com/advisories/cve-2015-1426 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: facter 2.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems facter: affected >= 1.6.0, < 2.4.1; fixed in 2.4.1 ## Suggested inspection (read-only) - RubyGems facter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on facter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j436-h7hm-rx46 (GitHub-reviewed advisory GHSA-j436-h7hm-rx46 lists affected ranges: RubyGems facter >=1.6.0 <2.4.1) Commands are suggestions: review each one before running it.
Loading voting…