Skip to content

← Actionable
High, CVSS 8.1

LXD vulnerable to Race Condition

CVE-2015-1340GHSA-8mpq-fmr3-6jxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lxc/lxd 0.0.0-20151004155856-19c6961cc101), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/lxc/lxd

    Affected
    < 0.0.0-20151004155856-19c6961cc101
    Fixed in
    0.0.0-20151004155856-19c6961cc101

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-1340: 0.90% estimated exploitation activity in the next 30 days; percentile 59.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

LXD before version 0.19-0ubuntu5 doUidshiftIntoContainer() has an unsafe Chmod() call that races against the stat in the Filepath.Walk() function. A symbolic link created in that window could cause any file on the system to have any mode of the attacker's choice. Specific Go Packages Affected github.com/lxc/lxd/shared

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8mpq-fmr3-6jxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-1340

Advisory: LXD vulnerable to Race Condition
IDs: CVE-2015-1340, GHSA-8mpq-fmr3-6jxv
Record: https://patchnext.com/advisories/cve-2015-1340 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/lxc/lxd 0.0.0-20151004155856-19c6961cc101. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/lxc/lxd: affected < 0.0.0-20151004155856-19c6961cc101; fixed in 0.0.0-20151004155856-19c6961cc101

## Suggested inspection (read-only)
- Go github.com/lxc/lxd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/lxc/lxd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8mpq-fmr3-6jxv (GitHub-reviewed advisory GHSA-8mpq-fmr3-6jxv lists affected ranges: Go github.com/lxc/lxd >=0 <0.0.0-20151004155856-19c6961cc101)

Commands are suggestions: review each one before running it.

Loading voting…