Skip to content

← Actionable
Low, CVSS 3.1

Open Redirect in serve-static

CVE-2015-1164GHSA-c3x7-gjmx-r2ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (serve-static 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm serve-static

    Affected
    < 1.7.2>= 1.7.0, < 1.7.2
    Fixed in
    1.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2015-1164: 2.62% estimated exploitation activity in the next 30 days; percentile 85.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of `serve-static` prior to 1.6.5 ( or 1.7.x prior to 1.7.2 ) are affected by an open redirect vulnerability on some browsers when configured to mount at the root directory.

Proof of Concept A link to `http://example.com//www.google.com/%2e%2e` will redirect to `//www.google.com/%2e%2e` Some browsers will interpret this as `http://www.google.com/%2e%2e`, resulting in an external redirect.

Recommendation Version 1.7.x: Update to version 1.7.2 or later. Version 1.6.x: Update to version 1.6.5 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-c3x7-gjmx-r2ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-1164

Advisory: Open Redirect in serve-static
IDs: CVE-2015-1164, GHSA-c3x7-gjmx-r2ff
Record: https://patchnext.com/advisories/cve-2015-1164 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: serve-static 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm serve-static: affected < 1.7.2; >= 1.7.0, < 1.7.2; fixed in 1.7.2

## Suggested inspection (read-only)
- `npm ls serve-static --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on serve-static.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c3x7-gjmx-r2ff (OSV record GHSA-c3x7-gjmx-r2ff lists affected ranges: npm serve-static >=0 =1.7.0 <1.7.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…