Skip to content

← Actionable
High, CVSS 7.5

GoPistolet vulnerable to Improper Resource Shutdown or Release

CVE-2015-10085GHSA-wr8h-w969-36m8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gopistolet/gopistolet 0.0.0-20210418093520-a5395f728f8d), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2015-10085: 0.95% estimated exploitation activity in the next 30 days; percentile 61.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in GoPistolet. It has been declared as problematic. This vulnerability affects unknown code of the component MTA. The manipulation leads to denial of service. Continious delivery with rolling releases is used by this product. Therefore, no version details of affected nor updated releases are available. The name of the patch is b91aa4674d460993765884e8463c70e6d886bc90. It is recommended to apply a patch to fix this issue. VDB-221506 is the identifier assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wr8h-w969-36m8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-10085

Advisory: GoPistolet vulnerable to Improper Resource Shutdown or Release
IDs: CVE-2015-10085, GHSA-wr8h-w969-36m8
Record: https://patchnext.com/advisories/cve-2015-10085 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/gopistolet/gopistolet 0.0.0-20210418093520-a5395f728f8d. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/gopistolet/gopistolet: affected < 0.0.0-20210418093520-a5395f728f8d; fixed in 0.0.0-20210418093520-a5395f728f8d

## Suggested inspection (read-only)
- Go github.com/gopistolet/gopistolet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/gopistolet/gopistolet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wr8h-w969-36m8 (GitHub-reviewed advisory GHSA-wr8h-w969-36m8 lists affected ranges: Go github.com/gopistolet/gopistolet >=0 <0.0.0-20210418093520-a5395f728f8d)

Commands are suggestions: review each one before running it.

Loading voting…