Skip to content

← Actionable
Critical, CVSS 9.6

tinymighty WikiSEO is vulnerable to cross-site scripting via modifyHTML function

CVE-2015-10073GHSA-84mm-prjg-49xm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymighty/wiki-seo 1.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2015-10073: 0.88% estimated exploitation activity in the next 30 days; percentile 59.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in tinymighty WikiSEO 1.2.1. This affects the function modifyHTML of the file WikiSEO.body.php of the component Meta Property Tag Handler. The manipulation of the argument content leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.2.2 is able to address this issue. The name of the patch is 089a5797be612b18a820f9f1e6593ad9a91b1dba. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220215.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-84mm-prjg-49xm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-10073

Advisory: tinymighty WikiSEO is vulnerable to cross-site scripting via modifyHTML function
IDs: CVE-2015-10073, GHSA-84mm-prjg-49xm
Record: https://patchnext.com/advisories/cve-2015-10073 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tinymighty/wiki-seo 1.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist tinymighty/wiki-seo: affected < 1.2.2; fixed in 1.2.2

## Suggested inspection (read-only)
- Packagist tinymighty/wiki-seo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tinymighty/wiki-seo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-84mm-prjg-49xm (GitHub-reviewed advisory GHSA-84mm-prjg-49xm lists affected ranges: Packagist tinymighty/wiki-seo >=0 <1.2.2)

Commands are suggestions: review each one before running it.

Loading voting…