Skip to content

← Actionable
Critical, CVSS 9.8

kelvinmo simplexrd vulnerable to Improper Restriction of XML External Entity Reference

CVE-2015-10029GHSA-rh3m-pr36-xh2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kelvinmo/simplexrd 3.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-10029: 0.85% estimated exploitation activity in the next 30 days; percentile 58.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability classified as problematic was found in kelvinmo simplexrd up to 3.1.0. This vulnerability affects unknown code of the file simplexrd/simplexrd.class.php. The manipulation leads to xml external entity reference. Upgrading to version 3.1.1 is able to address this issue. The name of the patch is 4c9f2e028523ed705b555eca2c18c64e71f1a35d. It is recommended to upgrade the affected component. VDB-217630 is the identifier assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rh3m-pr36-xh2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-10029

Advisory: kelvinmo simplexrd vulnerable to Improper Restriction of XML External Entity Reference
IDs: CVE-2015-10029, GHSA-rh3m-pr36-xh2f
Record: https://patchnext.com/advisories/cve-2015-10029 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kelvinmo/simplexrd 3.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kelvinmo/simplexrd: affected < 3.1.1; fixed in 3.1.1

## Suggested inspection (read-only)
- Packagist kelvinmo/simplexrd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kelvinmo/simplexrd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rh3m-pr36-xh2f (GitHub-reviewed advisory GHSA-rh3m-pr36-xh2f lists affected ranges: Packagist kelvinmo/simplexrd >=0 <3.1.1)

Commands are suggestions: review each one before running it.

Loading voting…